ID:

CVE-2018-18506 (NVD)

- Vulnerability Info (edit)
2019-02-05

When proxy auto-detection is enabled, if a web server serves a Proxy Auto-Configuration (PAC) file or if a PAC file is loaded locally, this PAC file can specify that requests to the localhost are to be sent through the proxy to another server. This behavior is disallowed by default when a proxy is manually configured, but when enabled could allow for attacks on services and tools that bind to the localhost for networked behavior if they are accessed through browsing. This vulnerability affects Firefox < 65.

Products Ubuntu_linux, Debian_linux, Firefox, Leap, Enterprise_linux_desktop, Enterprise_linux_server, Enterprise_linux_server_aus, Enterprise_linux_server_eus, Enterprise_linux_server_tus, Enterprise_linux_workstation
Type 7PK - Security Features (CWE-254)
First patch - None (likely due to unavailable code)
Links https://security.gentoo.org/glsa/201904-07
http://lists.opensuse.org/opensuse-security-announce/2019-03/msg00043.html
https://lists.debian.org/debian-lts-announce/2019/03/msg00024.html
https://access.redhat.com/errata/RHSA-2019:0680
https://usn.ubuntu.com/3874-1/
Annotation

Note:

No patch was assigned yet.