ID:

CVE-2019-16781 (NVD)

- Vulnerability Info (edit)
2019-12-26

In WordPress before 5.3.1, authenticated users with lower privileges (like contributors) can inject JavaScript code in the block editor, which is executed within the dashboard. It can lead to an admin opening the affected post in the editor leading to XSS.

Products Wordpress
Type Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') (CWE-79)
First patch - None (likely due to unavailable code)
Patches https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-pg4x-64rh-3c9v
Links https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/
https://wpvulndb.com/vulnerabilities/9976
https://hackerone.com/reports/731301
https://www.debian.org/security/2020/dsa-4599
https://seclists.org/bugtraq/2020/Jan/8
Annotation

Note:

No patch was assigned yet.