ID:

CVE-2019-11365 (NVD)

- Vulnerability Info (edit)
2019-04-20

An issue was discovered in atftpd in atftp 0.7.1. A remote attacker may send a crafted packet triggering a stack-based buffer overflow due to an insecurely implemented strncpy call. The vulnerability is triggered by sending an error packet of 3 bytes or fewer. There are multiple instances of this vulnerable strncpy pattern within the code base, specifically within tftpd_file.c, tftp_file.c, tftpd_mtftp.c, and tftp_mtftp.c.

Products Atftp
Type Improper Restriction of Operations within the Bounds of a Memory Buffer (CWE-119)
First patch - None (likely due to unavailable code)
Links https://lists.debian.org/debian-lts-announce/2019/05/msg00012.html
https://sourceforge.net/p/atftp/code/ci/abed7d245d8e8bdfeab24f9f7f55a52c3140f96b/
https://pulsesecurity.co.nz/advisories/atftpd-multiple-vulnerabilities
https://www.debian.org/security/2019/dsa-4438
https://seclists.org/bugtraq/2019/May/16
Annotation

Note:

No patch was assigned yet.