ID:

CVE-2019-11253 (NVD)

- Vulnerability Info (edit)
2019-10-17

Improper input validation in the Kubernetes API server in versions v1.0-1.12 and versions prior to v1.13.12, v1.14.8, v1.15.5, and v1.16.2 allows authorized users to send malicious YAML or JSON payloads, causing the API server to consume excessive CPU or memory, potentially crashing and becoming unavailable. Prior to v1.14.0, default RBAC policy authorized anonymous users to submit requests that could trigger this vulnerability. Clusters upgraded from a version prior to v1.14.0 keep the more permissive policy by default for backwards compatibility.

Products Kubernetes
Type Improper Input Validation (CWE-20)
First patch - None (likely due to unavailable code)
Patches https://github.com/kubernetes/kubernetes/issues/83253
Links https://access.redhat.com/errata/RHSA-2019:3239
https://groups.google.com/forum/#!topic/kubernetes-security-announce/jk8polzSUxs
Annotation

Note:

No patch was assigned yet.