ID:

CVE-2018-7284 (NVD)

- Vulnerability Info (edit)
2018-02-21

A Buffer Overflow issue was discovered in Asterisk through 13.19.1, 14.x through 14.7.5, and 15.x through 15.2.1, and Certified Asterisk through 13.18-cert2. When processing a SUBSCRIBE request, the res_pjsip_pubsub module stores the accepted formats present in the Accept headers of the request. This code did not limit the number of headers it processed, despite having a fixed limit of 32. If more than 32 Accept headers were present, the code would write outside of its memory and cause a crash.

Products Debian_linux, Asterisk, Certified_asterisk
Type Improper Restriction of Operations within the Bounds of a Memory Buffer (CWE-119)
First patch - None (likely due to unavailable code)
Links https://www.debian.org/security/2018/dsa-4320
http://www.securityfocus.com/bid/103151
https://www.exploit-db.com/exploits/44184/
http://www.securitytracker.com/id/1040416
http://downloads.asterisk.org/pub/security/AST-2018-004.html
Annotation

Note:

No patch was assigned yet.