ID:

CVE-2018-20354 (NVD)

- Vulnerability Info (edit)
2019-06-10

An invalid read of 8 bytes due to a use-after-free vulnerability during a "return" in the mg_http_get_proto_data function in mongoose.c in Cesanta Mongoose Embedded Web Server Library 6.13 and earlier allows a denial of service (application crash) or remote code execution.

Products Mongoose
Type Use After Free (CWE-416)
First patch - None (likely due to unavailable code)
Patches https://github.com/insi2304/mongoose-6.13-fuzz/blob/master/Simplest_Web_Server_Use_After_Free-read-mg_http_get_proto_data.png
Annotation

Note:

No patch was assigned yet.