ID:

CVE-2018-1334 (NVD)

- Vulnerability Info (edit)
2018-07-12

In Apache Spark 1.0.0 to 2.1.2, 2.2.0 to 2.2.1, and 2.3.0, when using PySpark or SparkR, it's possible for a different local user to connect to the Spark application and impersonate the user running the Spark application.

Products Spark
Type Information Exposure (CWE-200)
First patch - None (likely due to unavailable code)
Links https://lists.apache.org/thread.html/4d6d210e319a501b740293daaeeeadb51927111fb8261a3e4cd60060@%3Cdev.spark.apache.org%3E
https://spark.apache.org/security.html#CVE-2018-1334
Annotation

Note:

No patch was assigned yet.