ID:

CVE-2016-9011 (NVD)

- Vulnerability Info (edit)
2017-03-23

The wmf_malloc function in api.c in libwmf 0.2.8.4 allows remote attackers to cause a denial of service (application crash) via a crafted wmf file, which triggers a memory allocation failure.

Products Libwmf
Type Improper Restriction of Operations within the Bounds of a Memory Buffer (CWE-119)
First patch - None (likely due to unavailable code)
Links https://bugzilla.redhat.com/show_bug.cgi?id=1388450
http://www.securityfocus.com/bid/93860
https://blogs.gentoo.org/ago/2016/10/18/libwmf-memory-allocation-failure-in-wmf_malloc-api-c
http://www.openwall.com/lists/oss-security/2016/10/25/1
Annotation

Note:

No patch was assigned yet.