ID:

CVE-2013-3675 (NVD)

- Vulnerability Info (edit)
2013-06-10

The process_frame_obj function in sanm.c in libavcodec in FFmpeg before 1.2.1 does not validate width and height values, which allows remote attackers to cause a denial of service (integer overflow, out-of-bounds array access, and application crash) via crafted LucasArts Smush video data.

Products Ffmpeg
Type Improper Input Validation (CWE-20)
First patch - None (likely due to unavailable code)
Patches http://git.videolan.org/?p=ffmpeg.git;a=commit;h=9dd04f6d8cdd1c10c28b2cb4252c1a41df581915
http://git.videolan.org/?p=ffmpeg.git;a=commit;h=524d0d2cfc7bab1b348f85e7c0369859e63781cf
Links http://ffmpeg.org/security.html
Annotation

Note:

No patch was assigned yet.